Tilt and trim leak
Results 1 to 5 of 5

Thread: Tilt and trim leak

  1. #1
    Join Date
    Jul 2012
    Location
    NC
    Posts
    22

    Tilt and trim leak

    The last 2 trips I've taken my tilt has stopped operating when I loaded the boat to leave. In both cases I have refilled with fluid and both tilt and trim have performed flawlessly. I have raised and lowered repeatedly. Probably run more than I would have used it on a trip on the water. There are no sign of any leak. I have put white cloths under the motor and it shows nothing. The motor is a Johnson 150 outboard. The trim gauge has stopped working and I'm not sure if it works on pressure. Is there anywhere inside the hull that may be related to this gauge where there may be a leak? Please advise as to where I may need to track to find where the tilt/trim fluid may be going. Thank you in advance for any response!!!

  2. #2
    Join Date
    Jan 2017
    Posts
    81
    Duplicate post.delete
    Last edited by ReelHooked757; Yesterday at 08:17 PM.

  3. #3
    Join Date
    Jan 2017
    Posts
    81
    .

  4. Remove Advertisements
    PierAndSurf.com
    Advertisements
     

  5. #4
    Join Date
    Jan 2017
    Posts
    81
    When tilt trim leaks ,its the seals onthr cylinders . If you store your engine down then it usually won't leak. You engine must be in the up position,for you to see or reproduce a leaking cylinder.

  6. #5
    Join Date
    Jul 2012
    Location
    NC
    Posts
    22
    Motor has been stored down....

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •